Alien_cp not working, complaining about XRootD


for some reason I cannot use alien_cp on my ubuntu laptop at the moment. When I do this command:

alien_cp alien:///alice/data/2021/OCT/505673/raw/0640/ file:.

I get the error message:
“DO_XrootdCp:: python XRootD module not found or lower than 5.3.3, the copy process cannot continue”

But I do have a recent version of XRootD installed and loaded (5.4.2):

alienv list
Currently Loaded Modulefiles:
 1) BASE/1.0                         9) libpng/v1.6.34-3        17) pythia/v8304-11          25) libxml2/v2.9.3-2        33) simulation/v1.0-local1   41) Vc/1.4.1-4                   49) Common-O2/v1.6.0-11       57) fastjet/v3.4.0_1.045-alice1-local1  
 2) O2DPG/latest-master-o2          10) Python-modules/1.0-10   18) pythia6/428-alice2-3     26) XRootD/v5.4.2-alice1-1  34) ZeroMQ/v4.3.3-5          42) HepMC3/3.2.2-local1          50) ms_gsl/4.0.0-1            58) libjalienO2/0.1.3-5                 
 3) GCC-Toolchain/v10.2.0-alice2-2  11) boost/v1.75.0-10        19) generators/v1.0-local1   27) lzma/v5.2.3-2           35) ofi/v1.14.0-2            43) curl/7.70.0-4                51) libuv/v1.40.0-4           59) KFParticle/v1.1-4-local1            
 4) zlib/v1.2.8-2                   12) protobuf/v3.15.8-4      20) fmt/8.0.1-3              28) ROOT/v6-24-06-local1    36) asio/v1.19.1-4           44) libInfoLogger/v2.4.3-3       52) GLFW/3.3.2-4              60) FFTW3/v3.3.9-7                      
 5) OpenSSL/v1.0.2o-2               13) Clang/v13.0.0-3         21) FairLogger/v1.10.4-4     29) VMC/v1-1-p1-local1      37) asiofi/v0.5.1-7          45) ApMon-CPP/v2.2.8-alice5-2    53) DebugGUI/v0.6.2-3         61) O2/latest-dev-o2                    
 6) lz4/v1.9.3-3                    14) utf8proc/v2.6.1-4       22) GSL/v1.16-3              30) vgm/v4-9-local1         38) DDS/3.7.3-2              46) Monitoring/v3.11.0-local1    54) xjalienfs/1.3.7-local1    
 7) AliEn-Runtime/v2-19-le-4        15) arrow/v5.0.0-alice3-8   23) GEANT4/v10.7.2-alice1-1  31) GEANT4_VMC/v5-4-local1  39) FairMQ/v1.4.49-local1    47) Ppconsul/v0.2.2-10           55) JAliEn-ROOT/0.6.6-local1  
 8) FreeType/v2.10.1-5              16) lhapdf/v6.2.1-alice2-3  24) TBB/v2021.5.0-4          32) GEANT3/v3-9-local1      40) FairRoot/v18.4.2-local1  48) Configuration/v2.6.3-local1  56) cgal/4.12.2-12

Has anyone else seen this problem and has possibly a solution for it?


Ciao @oschmidt ,

Do you have this PR?


Yes, I have that included, but I still get the error

I also see this error on my ubuntu PCs, was there any remedy found?

Hi Ruben,

I chatted about this with @asevcenc in the JAlien channel on MM and with his help I found a workaround. I checked out XRootD in the version 5.4.2-alice1 as development package and then recompiled O2. alien_cp works for me now. But unfortunately the issue is not really understood.
I am also still using an older version of alidist, because of O2 build fails on: xjalienfs - ubuntu 20.04, possible setuptools issue


Thanks @oschmidt
Will try with XRootD as dev. package.

just to add another point in the picture :slight_smile: : i just tried it on a fresh ubuntu 20.04.4 installation
with up to date alidist and alibuild and xrootd (and it’s usage by worked without problems …
just for reference i have these installed in the system:
apt list --installed 2>/dev/null| grep -E “python3-((pip)|(setup)|(wheel)).*”
python3-pip/focal-updates,focal-updates,now 20.0.2-5ubuntu1.6 all [installed]
python3-setuptools-git/focal,focal,now 1.2-3 all [installed]
python3-setuptools/focal,focal,now 45.2.0-1 all [installed]
python3-wheel/focal,focal,now 0.34.2-1 all [installed]

and in the user also i do:
python3 -m pip install --no-cache-dir --user --upgrade pip setuptools wheel