Errors loading qcg or O2

Dear all,

I have just updated my alidist, O2 and QualityControl to the most recent master or dev. The compilation with the following command (using qcg) is fine:

aliBuild build qcg --defaults o2

But when I now try to load with

alienv enter qcg/latest-o2

I get the following error:

abseil/20200225.2-5(9):ERROR:102: Tcl command execution failed: prepend-path PATH $ABSEIL_ROOT/bin

The other packages seem to be loaded all fine, but when I e.g. try to run an O2 simulation with:

o2-sim -m TPC [ITS PIPE] -n 100 -g pythia8

I get the following errors:

[FATAL] O2_ROOT environment not defined
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_M_construct null not valid
Aborted (core dumped)

@tklemenz has observed the same issue last week. He was still able to load O2, though, which I now even cannot. When trying to load just O2 using:

 alienv enter O2/latest-dev-o2

I get:

FairRoot(6):ERROR:105: Unable to locate a modulefile for 'FairRoot/6af7e84858-13'
DDS(6):ERROR:105: Unable to locate a modulefile for 'DDS/3.1-3'
Vc(6):ERROR:105: Unable to locate a modulefile for 'Vc/1.4.1-4'
HepMC3(6):ERROR:105: Unable to locate a modulefile for 'HepMC3/v3.0.0-git_d43693ce0e-11'
Monitoring(6):ERROR:105: Unable to locate a modulefile for 'Monitoring/v2.6.4-3'
Configuration(6):ERROR:105: Unable to locate a modulefile for 'Configuration/v2.2.5-1'
libInfoLogger(6):ERROR:105: Unable to locate a modulefile for 'libInfoLogger/v1.3.7-6'
Common-O2(6):ERROR:105: Unable to locate a modulefile for 'Common-O2/v1.4.6-6'
arrow(12):ERROR:105: Unable to locate a modulefile for 'arrow/v0.14.1-11'
DebugGUI(12):ERROR:105: Unable to locate a modulefile for 'DebugGUI/v0.1.0-655f92e9c9-1'
AEGIS(12):ERROR:105: Unable to locate a modulefile for 'AEGIS/v1.0-11'
Currently Loaded Modulefiles:
  1) BASE/1.0           2) ms_gsl/1-4         3) O2/latest-dev-o2
Use alienv list to list loaded modules. Use exit to exit this environment.

Thus, in this case I cannot even test, if the simulation would work, because I cannot load the environment at all.

I am running on an Ubuntu 18.04 machine and the last time I have updated my O2 etc. everything was fine, but this is also already a couple of weeks ago. I also tried an aggressive cleanup, another update of alidist/O2/QC and recompiling, but this did not help.

Any help would be appreciated!


Just to confirm one point that is not completely clear to me and to restrain the scope of the problem:
Have you tried to compile just O2 or QualityControl and then do the respective alienv enter O2/latest ? or did you always build qcg ?

For QCG, I am trying on my mac with the master of alidist. I’ll let you know if I get the same.


On Mac there are no errors loading the qcg. I tried with the master of alidist. However, I realize that I use the defaults o2-dataflow.


thanks for checking! I have also tried to compile only O2, but this just told me, that nothing would have to be recompiled, and hence the attempt to load it failed with the same errors.

Here is an update from my side: after trying several things I “managed” to completely screw up my O2 installation. Thus, I started from scratch, first only building O2. This went fine including the loading of the environment and running a simulation.

Afterwards, I did also again the init for QC and compilation with qcg as described in the first comment in this topic. As before, compilation runs fine, but I get the same error with abseil when loading qcg. And again, I get the same errors when trying to run an O2 simulation, although abseil should not even be needed for it.

At least, now loading only O2 works again, also after having installed QC. So the second part, i.e. loading a pure O2 and running a simulation, is working again. But loading qcg still fails as described above. This is btw. the same state Thomas is encountering since last week.

@hristov This is on Ubuntu, would you mind having a look ? thank you

Dear Barth, dear all,

with a recent update of alidist, O2 and QC, this issue is solved. I see, that there was among other things an update of the abseil recipe, probably this one solved this issue. We (both Thomas and I) are now able again to load qcg correctly and in this environment run an O2 simulation and a QC task.

Thanks for fixing this, whoever took care!


Good news, thank you for letting us know.