O2 build failing


I am trying to download and build O2 on a new system, which is a CERN CentOS7 virtual machine.

I am getting many errors similar to:

DEBUG:O2:O2:0: CMake Error at cmake/O2AddExecutable.cmake:94 (add_executable):
DEBUG:O2:O2:0: Target “O2test-framework-benchmark_DataDescriptorMatcher” links to target
DEBUG:O2:O2:0: “AliceO2::DebugGUI” but the target was not found. Perhaps a find_package()
DEBUG:O2:O2:0: call is missing for an IMPORTED target, or an ALIAS target is missing?
DEBUG:O2:O2:0: Call Stack (most recent call first):
DEBUG:O2:O2:0: cmake/O2AddTest.cmake:92 (o2_add_executable)
DEBUG:O2:O2:0: Framework/Core/CMakeLists.txt:226 (o2_add_test)

This is what I get at the very end, I have tried the suggestion but it still doesn’t work.

ERROR:O2:O2:0: Note that you have packages in development mode.
ERROR:O2:O2:0: Devel sources are not updated automatically, you must do it by hand.
ERROR:O2:O2:0: This problem might be due to one or more outdated devel sources.
ERROR:O2:O2:0: To update all development packages required for this build it is usually sufficient to do:
ERROR:O2:O2:0: ( cd O2 && git pull --rebase )


Hi Gianluca,

you may have to install GLFW on your system, see this ticket and the QC QuickStart page.

Hope, it helps!


Great thanks, that worked! I was seeing another documentation and that library was not mentioned.