Problems in aliBuild dependencies detection

Hi @laphecet

After multiple problems with rebuilding O2 with the help of @eulisse we found that if some module (ROOT in my case) have multiple version built, then the recompilation fails because the dependencies/O2FindDependenciesFromAliBuild.cmake picks the …alice/sw/ubuntu1804_x86-64/ROOT/latest.
I had O2 then AliRoot built with aliBuild, so that my ~/alice/sw/ubuntu1804_x86-64/ROOT/latest was linked to ~/alice/sw/ubuntu1804_x86-64/ROOT/v5-34-30-alice10-1 rather then to ~/alice/sw/ubuntu1804_x86-64/ROOT/v6-18-00-1.
Since the O2FindDependenciesFromAliBuild.cmake picks latest the incremental build fails.
Do you see solution to this?


See also

@shahoian I’m trying to reproduce the issue (and test a solution). I assume the following lines, in that order, would do it :

aliBuild build O2 --defaults o2
aliBuild build AliRoot --defaults XXX

I’m not so sure about which defaults to use for AliRoot though. Tried “user” or nothing at all but I get an error compiling Root (ROOT@v5-34-30-alice10) (I’m trying this on Unbuntu 18.04). Note that O2 compilation is OK.

Error: cannot open file “gnu/stubs.h” /usr/include/features.h:449:
Error: cannot open file “bits/dlfcn.h” /usr/include/dlfcn.h:28:
Error: Symbol Dl_info is not defined in current scope /usr/include/dlfcn.h:94:
Error: Missing whitespace at or after line 189.
Error: Unexpected end of file (G__fgetspace():2) /usr/include/dlfcn.h:191:
Error: …/…/bin/rootcint_tmp: error loading headers…

Any idea what’s wrong with my setup ?

Hi @laphecet,

Sorry for late response, missed the question since was on vacation…
I build aliroot just with aliBuild build AliRoot, w/o providing any option,
this will build it with root5.


Hi @shahoian,

OK. Tried aliBuild build Aliroot but I’m still running into the same compilation issues with ROOT 5 on my Ubuntu VM (cannot open file “gnu/stubs.h” etc… when compiling TMVA)

Is there something special to be installed for ROOT5 ?