QCG crashes due to missing ServiceRegistry.h

Dear all,

I have just updated all the software (alidist, O2, QualityControl) and tried to compile with QCG, but unfortunately it fails. Originally, I had installed the local QCG corresponding to these instructions and for compilation I run

aliBuild build qcg --defaults o2

The last time I did this (a bit more than a week ago) this was still working fine, but now it crashes in qcg with the following error message:

In file included from /home/sheckel/alice/sw/ubuntu1804_x86-64/QualityControl/master-1/include/QualityControl/DatabaseFactory.h:21:0,
                 from ../tobject2json.cc:2:
/home/sheckel/alice/sw/ubuntu1804_x86-64/QualityControl/master-1/include/QualityControl/DatabaseInterface.h:24:10: fatal error: Framework/ServiceRegistry.h: No such file or directory
 #include <Framework/ServiceRegistry.h>
compilation terminated.

I checked and, indeed, there is no file named ServiceRegistry.h, actually nowhere within QC. The full log can be found here.

I would be happy about any help on this!


Framework/ServiceRegistry.h files should come from AliceO2. @eulisse
Any idea
I’ve seen the same error message in Jenkins: https://alijenkins.cern.ch/job/FLP/job/O2Suite%20-%20o2-dataflow%20-%20CC7%20-%20master/588/console

We have seen it in this PR: https://github.com/alisw/alidist/pull/2484

I am not able to reproduce it, even in the docker container. Trying more and debugging. Thank you for the logs.

@sheckel You can rollback to 8d865a5759e3ce3455bda9e8c7fa4769e586362e in QualityControl and the problem should go away. A more sturdy solution is of course on the way.

https://alice.its.cern.ch/jira/browse/QC-408 --> discussion continues there

Please make sure you have the latest / greatest O2.

aliBuild init O2@dev

Hi Guilio,

I tried the new init, actually, as alibuild complained about the packages being not compatible, I did:

aliBuild init O2@dev --defaults o2

This worked, but gave as ouput just:

WARNING: using existing recipes from ./alidist
WARNING: not cloning O2 since it already exists

==> Development directory . created for o2

I am not sure, if that is, what you had in mind. Is it mandatory or at least recommended to perform the init from time to time? In any case, afterwards I updated again my alidist/master, O2/dev and QualityControl/master and tried to recompile, but I still get the same error as before.

I will try the rollback of QualtiyControl now.

For completeness: I am running on Ubuntu 18.04

Going back to the older commit in QC indeed helps, the build went now through, thanks Barth for the hint!

And thanks for following this up, I am looking forward to a solution of the underlying issue.

I just tried, updating again all software to the most recent versions. The workaround solution provided on https://alice.its.cern.ch/jira/browse/QC-408 works fine for me. Thanks a lot!

Very good, thank you for checking it out.