XRootD does not compile, uuid.h missing

Dear all,

after updating alidist and O2 yesterday, XRootD now crashes while compiling with the following error messages:

[ 49%] Building CXX object src/XrdCl/CMakeFiles/XrdCl.dir/XrdClFileStateHandler.cc.o
[ 49%] Linking CXX shared library libXrdClient.so
/home/sheckel/alice/sw/SOURCES/XRootD/v4.11.1-rc1-alice/v4.11.1-rc1-alice/src/XrdCl/XrdClFileStateHandler.cc:45:10: fatal error: uuid/uuid.h: No such file or directory
 #include <uuid/uuid.h>
compilation terminated.
src/XrdCl/CMakeFiles/XrdCl.dir/build.make:348: recipe for target 'src/XrdCl/CMakeFiles/XrdCl.dir/XrdClFileStateHandler.cc.o' failed
make[2]: *** [src/XrdCl/CMakeFiles/XrdCl.dir/XrdClFileStateHandler.cc.o] Error 1
make[2]: *** Waiting for unfinished jobs....

I checked, and the “missing” file is actually available here:

So this seems rather weird to me. Today I retried, also updating alidist and O2 again, but I get the same error. If it is relevant: I am running on Ubuntu 18.04.

I would be grateful for any help!


I faced this earlier this week. Solved by installing package uuid-dev on Debian:
sudo apt-get install uuid-dev
This should work on Ubuntu as well.

Dear Rafael,

thanks a lot, it worked!