aliBuild fails while building ROOT on Ubuntu 20.04

I was building AliRoot using the command
aliBuild build AliPhysics --defaults user
but it fails everytime at ROOT.
I tried to interpret the log file but failed.
I am attaching the log file with password: anshu123

i am also facing same problem. please help me
Ameer mukhtar

Hi Ashish,
building with
--defaults user
will build ROOT 5 which is a legacy. Afaik building ROOT 5 on ubuntu 20 is not possible without quite some workarounds. You could build with
--defaults user-next-root6
which will build ROOT6.

Thanks Ole

Amukhtar build root 6 instead.

good morning: I got same problem compiling root6. The point is that the directory where the log file would be found is empty. When following your suggestion I get the following messages:
aliBuild build O2 --defaults user-next-root6
ERROR: Specified default `user-next-root6’ is not compatible with the packages you want to build.
ERROR: Valid defaults:
ERROR: - alo
ERROR: - o2
ERROR: - o2-dataflow
ERROR: - o2-dev-fairroot
ERROR: - o2-prod

@mahmoud if you want to build O2 probably want to use --defaults o2 as the error message also suggests

sorry. This was my first option. Then it crashed saying:

ROOT is being built (use --debug for full output): failed
ERROR: Error while executing /home/tariq/alice/sw/SPECS/ubuntu2004_x86-64/ROOT/v6-20-08-alice1-1/ on `tariq-VirtualBox’.

and as mentioned the building directory is empty. I looked at similar errors and found your contribution suggesting to use --defaults user-next-root6.

Without any log files it is of course hard to help… Can you try to add the --debug option to your aliBuild command? Then you should be able to see why the build fails

Hallo Ole,
I ran the tried with debug and it worked with ROOT !!! can not explain why? But it crashed at O2. If you could help? the Logfile is under the link below.

Hm, hard to say, the framework should build fine. In that case it is probably best to just update alidist (via git pull in the alice/alidist directory), update O2 the same way and then start the build again.
Unfortunately, this might take some time depending on how many packages need to be rebuild. But at least it should work…

unfortunately not!
For future readers: the solution was to delete everything and to start from scratch. It worked.