fails with O2

Dear all,

I have recently installed O2 and QC on Mac M1. I am facing a grid token issue while using I have tried all the solutions mentioned earlier carefully, but still I get an error when I load the environment and try

I tried the following.
Step 1. I downloaded a fresh certificate from the webpage by following: ALICE Analysis Tutorial
Step 2. Latest O2 and QC software: I have a decent experience on working with O2 and QC
Step 3. Test certificate

[QualityControl/latest] ~/TUM/alice %>
Enter PEM pass phrase: Could NOT establish connection (WebSocket) to 2001:1458:301:54::100:40:8097
SSLCertVerificationError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1000)')
Check the logfile: /Users/sbhawani/alien_py.log

Step 4. check certificate info

[QualityControl/latest] ~/TUM/alice %> cert-info
DN >>> DC=ch/DC=cern/OU=Organic Units/OU=Users/CN=bhsingh/CN=841481/CN=Bhawani Singh
ISSUER >>> DC=ch/DC=cern/CN=CERN Grid Certification Authority
BEGIN >>> 2024-06-07 10:52:12
EXPIRE >>> 2025-07-12 10:52:12

Step 5. I checked with the verification

[QualityControl/latest] ~/TUM/alice %> cert-verify
SSL Verification failed for /Users/sbhawani/.globus/usercert.pem

I have followed possible solutions from Adrian Sevcenco however I am facing still the same issue.

I checked my xcode installation. its rather recent

/usr/bin/xcodebuild -version
Xcode 15.4
Build version 15F31d

I wonder if someone has similar issues and if another solution exists.

Any help will be very appreciated.


This is your actual problem … check if central services can be connected with: checkAddr

Thanks for reply, I ran checkAddr

It passes all the checks surprisingly

[O2Physics/latest-master-o2] ~/TUM/alice %> checkAddr        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK

well, ok, but how is the IPv6 part? your error message show that it could not connect to 2001:1458:301:54::100:40 which is an IPv6 , and it implies that your computer have an IPv6 IP …

Aah, I had changed the workplace. Therefore, IP changed.

Here is the check for the IP with which I had posted the first message.

[QualityControl/latest] ~/TUM/alice %> checkAddr
2001:1458:301:54::100:30:8097        OK
2001:1458:301:54::100:32:8097        OK
2001:1458:301:54::100:31:8097        OK
2001:1458:301:54::100:23:8097        OK
2001:1458:301:54::100:26:8097        OK
2001:1458:301:54::100:29:8097        OK
2001:1458:301:54::100:14:8097        OK
2001:1458:301:54::100:2a:8097        OK
2001:1458:301:54::100:40:8097        OK
2001:1458:301:54::100:27:8097        OK
2001:1458:301:54::100:13:8097        OK
2001:1458:301:54::100:5:8097        OK
2001:1458:301:54::100:22:8097        OK
2001:1458:301:54::100:25:8097        OK
2001:1458:301:54::100:15:8097        OK
2001:1458:301:54::100:28:8097        OK
2001:1458:301:54::100:16:8097        OK
2001:1458:301:54::100:11:8097        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK        OK

It passes all the checks but still fails, unfortunately

weird … send me please the log obtained with:
also, just to be sure, please also try certkey-match which should work

I checked the matching, and it does match with passkeys

[QualityControl/latest] ~/TUM/alice %> certkey-match
Enter PEM pass phrase:
Cert/key match

Please find the log file
log.txt (3.5 KB)

could you check within your environment the output of this command:
openssl x509 -text -in $X509_CERT_DIR/CERN-GridCA.pem | grep 'Not Before\|Not After'

Many thanks for your help. Here is what I got

[QualityControl/latest] ~/TUM/alice %> openssl x509 -text -in $X509_CERT_DIR/CERN-GridCA.pem | grep 'Not Before\|Not After'
            Not Before: Mar 29 08:24:22 2022 GMT
            Not After : Mar 29 08:34:22 2032 GMT

uff… so i’m out of ideas … the last resort ideas:

  1. check on lxplus that using your certificate you can connect successfully
  2. delete sw folder and try a completely fresh install

Thanks for your help!

I made a fresh installation, but the problem still persists. I have now made a request to the ALICE computing group so that I can test my certificate on lxplus.

However, if you have any further suggestions, I am eagerly looking for a solution.