Building O2 fails at FairRoot

Dear experts,

I am trying to update O2 and QC on ubuntu 18.04. Using the latest O2 dev, QC master and alidist master repos aliBuild build O2Suite --defaults o2 fails while builing FairRoot.

The corresponding log file can be found here.

Any idea what is going wrong?


Hi Thomas,

I have updated everything only a few days ago and it still worked fine, as well on Ubuntu 18.04. Now, I hesitate to update again, but I have a few ideas to check, though certainly being no expert:

Does aliDoctor give any helpful output?

 aliDoctor O2 --defaults o2

Did you try one of the following:

aliBuild clean
aliBuild clean --aggressive

Looking at your log file, directly after all the Checking C++11 lines, I see the line:

-- fairsoft-config not found. Is SIMPATH or FAIRSOFT_ROOT set correctly?

Now looking at alidist/, I see for the Root includes (might be the problem here from the error messages?):


If I now enter my O2/QC environment, I get for


just nothing, so this is not set, at least not anymore when building everything is done. In the next lines in alidist/, there is a note about the SIMPATH, which has to be unset. This is also directly done with unset SIMPATH and looking for it with an echo $SIMPATH I as well get nothing back. Same for echo $FAIRSOFT_ROOT, which is also in the log. You could try all these to see, if maybe something is pointing to an older version of some of these and has not correctly been unset (for whatever reason).

One last point: in my alidist from May 07, I have as version for FairRoot the following tag (3rd line in alidist/

tag: "4ab2d2b1f0392ad93b92026d70fe049c38665f7d"

Should you already have another (more recent) version, you might want to try this one.

As I said, I am not an expert, just digging around a bit. Maybe it helps, otherwise maybe other people could comment.


Hi Stefan,

thanks for your effort.

aliDoctor O2 --defaults o2

gives no suspicious output and does not complain about anything.

Building after

aliBuild clean
aliBuild clean --aggressive

still gives the same result.

Iirc the FAIRROOT_ROOT variable was never set when loading the o2 environment so I don’t think that hints to anything. Probably that’s the same for SIMPATH and FAIRSOFT_ROOT.
On the other hand when I load o2 now I get some errors because some modules could not be found. I guess that is because it was not built properly so I don’t know how reliable checking for these variables is at the moment.

In my I have the same tag as you have.

I’ll try removing the whole sw folder. This worked wonders in the past. :slight_smile:

Edit: Did not help this time…


@eulisse, do you have an idea maybe?

I was stupid, this can be deleted…

Dear @tklemenz I’m facing the same problem… It seems from your last message that you found a trivial way to make the building work. Can you please share it?

Hi @nvalle, I had FairRoot as a development package and forgot to update it. I guess this won’t help you much.