Building O2 fails in DebugGUI

Dear all,

I was just trying to update my O2/dev. I have updated both O2 and alidist. Now, the compilation is failing in the DebugGUI with the following error:

-- Could NOT find GLFW (missing: GLFW_DIR)
CMake Error at DebugGUI/CMakeLists.txt:98 (install):
  install TARGETS given target "imgui_demo" which does not exist.

I do not have the GLFW installed, but I thought that this is optional (which is also written on the QualityControl QuickStart page). Is the GLFW now necessary?

Best regards,

No, it should not be mandatory nor necessary to have GLFW. This is something in O2 but I will give it a try.

I have removed GLFW from a build machine and recompiled O2 and QC. It worked.
The line number in the quote above is bothering me. There is no line 98 in DebugGUI/CMakeLists.txt. What is your platform ?
@eulisse any idea ?

Hi again,
Could you upload the full logs somewhere ?
Thank you,

I confirm that having GLFW should not be needed, but you do need to have the latest alidist. Can I see the logs of the build?


thanks for your quick responses!

Actually, I now see the GLFW indeed has been build this time, and it seems even successful, although I never installed it by myself - has anything changed here in the corresponding build recipe?

In any case, I uploaded both the output of aliBuild and the error log of the DebuiGUI to cernbox:
log (DebugGUI)

EDIT: If it helps, I am running on Ubuntu 18.04


Can you check if fixes the issue?

Unfortunately, it does not. Although I have to admit, that I now first updated alidist and found that there was only one commit reverting another commit from this morning. Then I realised, that the commit above is not yet in alidist. So I just changed this one line in the file, but without success.

Here, you can find the new debuggui log.

Thanks. The previous error seems actually to be solved. Can you try with 55c12c2?

Hi Giulio,

yes, this one works! Thanks a lot!


Dear Giulio, dear all,

yesterday evening I just tried by replacing this version of the DegubGUI myself and it worked. Now I have updated alidist/master, O2/dev and QualityControl/master and tried to recompile. DebugGUI is still fine, but now qcg is failing with the error:

../ In member function 'virtual void TObjectAsyncWorker::Execute()':
../ error: 'class o2::quality_control::repository::DatabaseInterface' has no member named 'retrieveJson'; did you mean 'retrieveMOJson'?
     output = BackendInstance->retrieveJson(path.substr(0, slashIndex), path.substr(slashIndex + 1));
                               retrieveMOJson recipe for target 'Release/' failed

Full log is again here at cernbox.


This is on us, we are going to provide a fix. Sorry for the problem, it passed through our CI.

The fix is in, but we are waiting for a new release here.

Sorry, I have just realized that all you have to do is to pull alidist from this PR and it should work.

I have to release QC before the PR of Adam can be merged…

Thanks! It worked for me. Actually, to be more precise, I first just pull alidist from the OGUI-471 branch and the build failed again, this time not even creating a log file. I tried updating also O2/dev and QualityControl/master, and after that everything compiled successfully.

Ok, good. I am preparing v0.20.0 of QualityControl that should solve in a more elegant way the whole issue.

Hi Barth,

I have seen the announcement that QC v0.20.0 has been released and hence, I have updated my O2/dev and QualityControl/master again and also wanted to update alidist/master. As I had this one commit changing the QCG version to 1.6.9 still in, I actually had to reset --hard alidist. After that, QCG failed again with the same error message as before. Now, I have rebased to the OGUI-471 branch and it works again. Is this the expected behaviour? Or have I maybe been just a little bit too fast? Although the last commit in QualityControl has the message v0.20.0, so this seems to be fine.


Hi Stefan,

The thing is that alidist is not yet up-to-date with the v0.20.0. The PR has not been merged yet :

As soon it is merged you should be able to proceed as you have already tried.

Ok thanks! Then indeed I have been a bit too fast. I will keep an eye on the PR and try again later.

I have similar error with today dev and alidist.
CMake Error at cmake/O2AddLibrary.cmake:69 (add_library):
Target “O2lib-Framework” links to target “AliceO2::DebugGUI” but the target
was not found. Perhaps a find_package() call is missing for an IMPORTED
target, or an ALIAS target is missing?
Call Stack (most recent call first):
Framework/Core/CMakeLists.txt:19 (o2_add_library)