Cannot run QC task anymore

Dear Experts,

I already installed O2 and the QualityControl software several times from scratch and although I can compile every package just fine, I end up with a segmentation violation if I run QC tasks.
I ran the following command:

o2-tpc-file-reader --tpc-track-reader ‘–infile tpctracks.root’ --input-type tracks | o2-qc --config json://…/Modules/TPC/run/tpcQCTracks_sampled.json

I uploaded the stack trace to my cern box:
https://cernbox.cern.ch/s/iEwEaEPNrAd1NBl

In the meantime I figured out that running without the graphical interface works and publishes the MOs correctly (as far as I can tell) on the qcg:
o2-tpc-file-reader -b --tpc-track-reader ‘–infile tpctracks.root’ --input-type tracks | o2-qc -b --config json://home/max/alice/QualityControl/Modules/TPC/run/tpcQCTracks_sampled.json

Thanks for the help & best,
Max

Hi,

Do you run it remotely ? via ssh ?

The debug gui does not work in such a case.

Cheers,
Barth

Dear Barth,

thanks for having a look. No, I run everything on my local machine. For now I can just develop the new code and don’t use the gui. However, I just want to avoid running into some trouble later down the line, clearly something does not work as intended.

Best,
Max

Hi,

Does it do it also for o2-qc-run-basic ?

Have you followed these instructions ? i.e. install glfw-devel?

Cheers,
Barth

Hi Barth,

yes, I followed the instructions, I did install libglfw3-dev (I hope this is what you mean) on my Ubuntu 22.04 system. This is also part of the prerequisites for AliPhysics, which runs just fine for me, but I made sure to also run sudo apt install libglfw3 libglfw3-dev and compile everything afterwards again. I checked the o2-qc-run-basic command, it also throws a segfault.

Best,
Max

Hi,

Ok, then I don’t know. Ubuntu is supported on a best effort for O2.
Perhaps @eulisse has an idea ?

Cheers,

Your graphics driver is trying to pickup the O2 LLVM which we use for other stuff and the two are incompatible. I am afraid the best option is to switch off the GUI using -b.

Could you also tell me what:

nm /home/max/alice/sw/ubuntu2204_x86-64/arrow/v11.0.0-alice1-12/lib/libgandiva.so.1100 | grep llvm | grep PMTopLevelManager | grep schedulePass

tells you?

Dear Giulio,

thanks for your comment, I am a bit puzzled why it works for all my colleagues who use Ubuntu systems. But as long as this is really not some underlying issue and just impacts the GUI it should be fine.
I executed the command you suggested and the output is the following:
nm /home/max/alice/sw/ubuntu2204_x86-64/arrow/v11.0.0-alice1-12/lib/libgandiva.so.1100 | grep llvm | grep PMTopLevelManager | grep schedulePass
0000000001faf340 t _ZN4llvm17PMTopLevelManager12schedulePassEPNS_4PassE
0000000001faf340 t _ZN4llvm17PMTopLevelManager12schedulePassEPNS_4PassE.localalias

Best,
Max

It depends on the graphics card driver, so if your colleagues have a different card / driver version it might misbehave. It only affects the GUI. I will try to do another pass to see if I can hide the incriminated symbols more (although nm already shows them as private, so I am puzzled).