Clang build fails on ubuntu 20.04

Dear Experts,

I’m struggling with the installation of O2 on a new ubuntu 20.04.
My latest problem is related with Clang, which fails to build at 21%
The logs are attached. I already tried playing with system libraries (including or excluding more of them). My system Clang version is currently 9 and 10, but aliBuild has a policy to build it anyway, so I can’t skip it…

aliDoctor.log (6.2 KB) Clang.log (404.5 KB)

Dear all,
I am facing the same problem with the present O2 setup - is there a known solution to this problem?
Thanks & best,

@mslupeck, looking at your log it looks like you have an old version of alidist. Could you try updating it?

This is an old issue (back from June). Since there was no response then, I switched to alidock and haven’t tried again with native ubuntu 20.04 with newer alidist

Ok. if you try again let me know. Next time, please, also use JIRA if you do not see any reply on discourse.

OK, I will.
I didn’t dig deeper before because ubuntu 20.04 was not supported at that time.

Updating alidist did the trick for me, sorry for the inconvenience…