CRU GBT Loopback


(Lars Bratrud) #1

Dear CRU experts,

I want to do some loopback tests on our TPC setup and tried using both loopback.py and gbtxChecker.py of cru-sw.

Loopback.py seem okay, but I am more interested in involving the fiber optics, so tried using gbtxChecker.py and am getting tons of errors…
Therefore I am wondering if there is something I am missing?

Do I use the --internal-loopback flag for standalone-startup.py? Both with and without shows lots of errors.
My init looks like this:
python ./cru-sw/COMMON/standalone-startup.py -i 4:0.0 -c ttc --pon-upstream --onu-address 3 -g wb -l 0,1,2,3,4,5,6,7,8,12,13,14,15,16,17,18,19,20 -x ttc -t pattern -m continuous --internal-loopback

Then I run the checker like this:
-bash-4.2$ python gbtxChecker.py -i 04:0.0 --pattern counter --link 0-2 -mode wb -s cnt -rst
seconds error:0 error:1 error:2
1 40128768 40129890 40130079
2 80255574 80256959 80257156
3 120345554 120346809 120346964

Any suggestions?


(Filippo Costa) #2

Ciao Lars, when you want to do test on the GBT loopback.py is the correct script.
It involves the optical fiber … so the only thing you have to do is to configure your card as you usually do when you take data from the FEC … loop the fiber and run the loopback script.
It will send the data over the fiber and check it back once is received in the CRU.

Cheers


(Lars Bratrud) #3

Ciao Pippo,

Ah, my understanding was that this loopback was only happening in the fabric and never left the CRU, alright.

But I also want to use the data generator in the GBTx to check FEC->CRU, and it seems like this new tool form one week ago can do this? How is the CRU supposed to be configured for this to work? Maybe @tunguyen can comment?


(Tuan Mate Nguyen) #4

Dear Lars,

I think the problem was that when you run the standalone-startup, you configured it to be in internal loopback mode. By default, the gbt tx mode is GBT, and for the gbt rx mode you set WB. These modes didn’t match so you saw errors (only loopback.py sets gbt tx mode to be the same as gbt rx mode, gbtxChecker doesn’t).

If you run the standalone without the --internal-loopback option, the gbt rx will get data from the FEC instead of the gbt tx, and there should be no errors.

Cheers,
Tuan


(Filippo Costa) #5

Adding my 2 certs.
The loopback.py is used to generate and check data on the GBT (it doesn’t matter if it is internally looped or if there is a fiber as Tuan explained).
The last tool will just display the gbt checker counters … that are always active. So if you send a test pattern from the FEC the GBT checker will check it and display the counters. We can have a dedicated session to show you how to use the tools.

Cheers


(Lars Bratrud) #6

Hello,
I also configured the CRU without internal-loopback option, but still see the same behavior.

The last tool will just display the gbt checker counters

These are the error counters that you read from the GBTs, right? Is the GBT set to bypass the e-link data from the FE? I was thinking maybe the GBT was comparing it’s test pattern to the data coming from our SAMPAs?

It would be cool to have a small session on it.


(Tuan Mate Nguyen) #7

Hello Lars,

When would you have time to sit together?

Cheers,
Tuan


(Lars Bratrud) #8

Hello,
Monday or Tuesday next week?


(Tuan Mate Nguyen) #9

Monday works for me