CRUv2 not recognized by FLP

I received one of the CRUv2 and also ordered one of the PowerEdge R740 servers configured as recommended by Uli. I just finished the hardware install, and also the OS install on the server (CentOS Linux release 7.5.1804 (Core)). I also went through the installation instructions for the flpproto software as described here ( as well as the Readout Card software installation described there. However, when I then tried to use roc-list-cards the list is empty. Is the CRU actually delivered with firmware already loaded or does that firmware first need to be loaded? Here are the commands I used:
[[root@gemini ~]# eval aliswmod load ReadoutCard/v0.8.8-3
[root@gemini ~]# roc-list-cards
infoLoggerD not available, falling back to stdout logging

Type PCI Addr Vendor ID Device ID Serial FW Version Card ID


Are there any other settings I need to worry about in the BIOS setup of that machine? Any other software packages I might not have installed?

Ciao Jo,
did you try to do a lspcie | grep -i altera

It should show the device.

You can find the latest firmware here

Add to your GRUB the following parameter

grubby --update-kernel=ALL --args=“ghes.disable=1”

to prevent the system from rebooting while loading the firmware in the FPGA

I am not aware of a lspcie command, the only command I found is the lspci command. That one did not show the Altera device.

sorry it was a typo.
Could you do again the same command grepping for cern?

If it show a device you have the wrong firmware and you should load one of the firmware I sent you with the link

Neither CERN nor Altera were found in the devices that lspci shows.
BTW, I attached a USB cable to the CRU, and the USB sees the Altera USB Blaster, so the board is at least alive

One maybe stupid question: Are all the PCIe slots in the R740 compatible with the CRU?

Yes they are.
Could you please try to load the firmware in the FLASH?
There is a pof file in the v1.3.0 folder.


I am having issues with CERNbox. I tried to download the files as a zip, but the resulting file was corrupted. So now I am downloading the files individually. CERNbox is being really slow…

After a long download, I now have installed the pof file into the flash, but after power cycling the server, I still don’t see it in the lspci command. Any other ideas?