Error on running o2-sim using Geant4

I tried to simulate using the command :

o2-sim -m ITS -e TGeant4 -g boxgen -n 10

But I got this error in o2-sim_workerlog():

[04:24:24][INFO] Add ITS alignable volumes
Info in TGeoManager::Export: Exporting FAIRGeom FAIR geometry as root file. Optimizations streamed.
Info in TObject::SetNavigator: TG4RootNavigator created and registered to G4TransportationManager

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : PART70000
issued by : G4NuclideTable
G4ENSDFSTATEDATA environment variable must be set
*** Fatal Exception *** core dump ***

*** Break *** segmentation violation

Does anyone know how to fix this?

when I run o2-sim -m ITS -e TGeant4 -g boxgen -n 10 everything seems fine. I also don’t see any errors in the workerlog. I just loaded the O2 environment with alienv load O2/latest-dev-o2

Did you solve this error? I’ve got exactly the same issue.

I have never observed this problem on our reference systems. To me it looks like a wrong or incomplete environment loaded by alienv. I would suggest to open a JIRA ticket with instructions how to reproduce this (operating system, alibuild version etc).