Failed building wheel for PyYAML

Dear experts,

I am trying to build O2 in BigSur 11.6 (Xcode 13.0). When trying the prerequisites, it fails at

brew install alisw/system-deps/o2-full-deps alisw/system-deps/alibuild

The instructions state that one should repeat it several times until there are no errors, but in this case it does not work. It always stops with the same error reported below.

NOTE: The error provides a suggestion, I do not have a /usr/local/Cellar/alibuild/ directory, so I cannot follow the suggestion …

I need my system running :frowning:
any help is welcome …
have a nice day


ps the error is:

==> /usr/local/Cellar/alibuild/1.8.9/libexec/bin/pip install -v --no-deps --no-binary :all: --ignore-installed /private/tmp/alibuild–PyYAML-20211009-34728-q7ccpa/PyYAML-5.4.1
Last 15 lines from /Users/jgcn/Library/Logs/Homebrew/alibuild/11.pip:
ERROR: Failed building wheel for PyYAML
Failed to build PyYAML
ERROR: Could not build wheels for PyYAML which use PEP 517 and cannot be installed directly
Exception information:
Traceback (most recent call last):
File “/usr/local/Cellar/alibuild/1.8.9/libexec/lib/python3.8/site-packages/pip/_internal/cli/”, line 180, in _main
status =, args)
File “/usr/local/Cellar/alibuild/1.8.9/libexec/lib/python3.8/site-packages/pip/_internal/cli/”, line 204, in wrapper
return func(self, options, args)
File “/usr/local/Cellar/alibuild/1.8.9/libexec/lib/python3.8/site-packages/pip/_internal/commands/”, line 360, in run
raise InstallationError(
pip._internal.exceptions.InstallationError: Could not build wheels for PyYAML which use PEP 517 and cannot be installed directly
WARNING: You are using pip version 21.1.1; however, version 21.2.4 is available.
You should consider upgrading via the ‘/usr/local/Cellar/alibuild/1.8.9/libexec/bin/python3 -m pip install --upgrade pip’ command.
Removed build tracker: ‘/private/tmp/pip-req-tracker-w5d0q_2k’

We have seen this happening when multiple python versions are installed. I would suggest:

  • Uninstall all python versions you have accumulated over the time with brew
  • Repeat the command to install alibuild

Dear Giulio

thanks for the hint, but it did not help. I had installed python 3.8 and 3.9. I had to use the option --ignore-dependencies because they were needed by gtk-doc, llvm, o2-full-deps and s3cmd already installed … Then I repeated the command and got the exact same error as reported before :((

Any other hint/idea that I may try?

thanks a lot

have a nice day


Sorry for losing focus on this. Did you manage to fix it? Can you try uninstalling and reinstalling bot alibuild and o2-full-deps?