Ft2build.h file not found

Dear all

I am working on OSX 10.15.6 with Xcode 12.0

Yesterday I installed AliPhysics. Then I tried to install O2, but it failed on Building DebugGUI@v0.2.0 because it cannot find ft2build.h. If I do
locate ft2build.h
I get:
so the file is there …

in the morning I updated both alidist and O2, but the error remained.

Any help is welcomed :slight_smile:
greetings from Prague


ps the full log is at

Looks like you have an old X11 installation. Can you remove it?

Hi Giulio

as far as I can tell(*) I have only one xcode version installed (in /Applications/Xcode.app/)
How can I find if I have another Xcode?


(*) I used ‘locate -i xcode | grep -v /Applications/Xcode.app/’ and went through the long list …

X11 / Xquartz, not XCode.

Hi Guilio

oops, sorry :frowning:

Now I have removed XQuartz completely and tried to comile again from Terminal. It fails … with the same error … the new log file is at



Can you try also brew reinstall freetype?

Dear Giulio

thanks a lot!
reinstalling freetype did the trick :slight_smile:

now O2 also compiled to the end.

have a nice day and greetings from Prague


Enjoy Prague! :slight_smile: