Links on QCDB are broken, missing "ccdb"

Dear all,

I am successfully connecting from the outside to the official QCG via these shifter instructions. When from there I access the QCDB via the link (within “About”) to the plotUrl, I get here: Adding a /browse to the link I get to what seems the correct QCDB, but from there on all links (i.e. on all levels) are broken. When you click on a link, the part /ccdb is removed from the url and you get a “Page not found” error. If you add back the /ccdb in the url, the directory structure is actually working, and in the end you can download the objects.

Now this is a bit annoying and I would like to ask, if this can be fixed. Or if there is another way to access the correct QCDB. I tried with the link provided on the shifter instructions page, but this lead here and seems not correct.


Hi @sheckel ,

The plotUrl is not the link representing the access to CCDB but a simple redirect we use for JSROOT to be able to plot the objects.

If you want to use the CCDB direct access you have to use the hostname and port options.

The above is the link that you should use to get access CCDB.
If this is confusing we can remove the plotURL option from being displayed

Thank you,

Hi George,

that link I actually had tried as well and it was leading nowhere. Now it is working, no idea what changed…

In any case, thanks for the info! I think, it is not necessary to remove the plotUrl, but maybe would be nice to add the correct link somewhere, either on the QCG or the shifter instructions.