Missing VMC library after (local) FLP Suite update

Dear experts,
here in Torino we have a CentOS 8 Stream node with FLP Suite which is used in the ZDC test setup.
After updating from 0.60.0 to 0.63.0 (2 days ago), some commands stopped working. In particular, the command o2-dpl-raw-proxy used in the QC workflow generation script now gives a missing library error

[flp@ali22xl ~]$ o2-dpl-raw-proxy
o2-dpl-raw-proxy: error while loading shared libraries: libVMCLibrary.so: cannot open shared object file: No such file or directory

As a consequence, I cannot create anymore an environment using the ZDC QC workflow I am testing.
I tried to re-run the installation command but nothing changed (I suppose, because it was already up-to-date). I searched for a RPM package with that name and apparently it contains no files

[flp@ali22xl ~]$ rpm -qa | grep VMC
[flp@ali22xl ~]$ rpm -ql o2-VMC-v2_0-5.slc8.x86_64
(contains no files)

I would be grateful for any suggestion. With my best regards


The fact the this executable is linked against libVMC is almost certainly a bug which should be fixed in some CMake. We need to trace down the component that introduces it.

Update: Unfortunately, this comes from O2::DetectorsBase … which is a requirement in many other places. Changing CMake will not be easy so we should fix the installation of the RPMs. @twilken

Hi, where are you getting your RPMs from? As far as I know, all our RPM package names start with alisw-, not o2-.

Hello Timo,
apologizes for the delay, I had exams. I am blindly following @costaf instructions:

bash <(curl -s https://cernbox.cern.ch/index.php/s/kNMAmYaN9l6RaKD/download)
dnf module disable mariadb:10.3
targethost=ali22xl ; o2-flp-setup deploy --head $targethost --flps $targethost

Many thanks for any suggestion. Kind regards


OK, thanks! Unfortunately, I don’t know much about how those are generated (i.e. f2r).

@awegrzyn, could you help debug?

Before I start debugging this can I just confirm that current version of VMC that we use in O2 is: v1_1_p1 while some time ago we were using v2-0. Is it intended?

Yes, according to alidist alidist/vmc.sh at master · alisw/alidist · GitHub, this is the correct version. We needed to return here because of problems seen in v2-0.

@sitta Could you just run dnf downgrade o2-VMC to move back to correct version?

many many thanks @awegrzyn ! It worked: now I have o2-VMC-v1_1_p1-10.slc8.x86_64 , and o2-dpl-raw-proxy and similar commands all work like a charm!
In case it happens again with next update (e.g. when a new FLP Suite is released), I can repeat this operation, right ?
Many thanks again. My best regards