Not able to access new QCDB from outside CERN

Dear all,

I try to access the new QCDB page from outside CERN:

Unfortunately, this does not work, I get “Server not found”. I am connected according to the instructions on the shifter doc and I am able to access the qcg under:

I also tried the old page:
Same issue here, this I cannot access as well, although I could access it few days ago. But maybe this one is just already obsolete?

I tried several other things, among them using https instead of http and accessing directly one object, which @bvonhall was actually able to access from outside at the same time, namely:

This also was not successful.

In the terminal, where I have the ssh connection running, I sometimes (but not at each failed attempt) get messages like:

channel 7: open failed: connect failed: No route to host


channel 10: open failed: connect failed: Connection refused

with different channels. Maybe this could help to identify the issue? Does my account have to be in any list of users allowed to access this page?

I would be happy about any ideas!

If it helps: I am using Firefox on Ubuntu 18.04.



I have been thinking about it last week but I don’t understand what is going on. Clearly the proxy is working as you can connect to the qcg.
Moreover, others are able to connect to the QCDB via a proxy.

Could you try with Chrome ? just to see.

Hi Barth,

now I tried again and the situation is even worse: I still can start the socks proxy server on lxplus7, but now I cannot even open the QCG, which I still had been able to access when I first found the issue with the QCDB on CS8.

Following your suggestion I also gave it a try with Chrome, but I have no experience with this browser. The only place to change the proxy I found is in Settings/Advanced/System, where there is a link to the system settings. Changing these according to the instructions on the shifter page, I also in Chrome could not access both QCG and QCDB, but maybe I have to do this differently in Chrome? Any idea?

In addition, when connecting to lxplus7 there is a message, that also “C8 based is now available”, so I tried this one assuming “C8” is “CS8”, and that this might be needed. Also here no success, I am not able to access both sides. No matter which proxy server, I get in its terminal error messages like:

channel 6: open failed: connect failed: No route to host
channel 16: open failed: connect failed: No route to host

So I think this is somehow connected, but I do not know, how… Do you maybe have any idea, whom else to ping here?


Short question, maybe @bvonhall or @pkonopka : are these servers affected by the AUG tests yesterday and maybe just still switched off at the moment, like e.g. ARC and everything in CR1? This might explain, why I now not even can access the QCG, which was still possible last week, though it would not explain my issues with the new QCDB already observed last week.

Sorry for the late reply. Yes they were affected.

Could you try again for QCDB and confirm that you still cannot connect ?

Thanks for the info. I can confirm that I am back to the old situation: accessing QCG works fine, but I still have no access to the QCDB.

Dear experts,
I’m currently having the same issue described by @sheckel. I’m able to access the QCG ( from outside via the lxplus proxy but the QCDB page ( gives a Server Not Found Error. I observe this behavior with both Firefox and Google Chrome on my CentOS8 machine.

With the lxplus proxy set up, I also tried using the CCDB API in a macro like shown below as a quick check to see if I can establish a direct connection:

> ccdb::CcdbApi api; 
> map<string, string> metadata;
> api.init(""); 
> string file_list = api.list("qc/TPC/MO/Clusters/.*");

Running this gives a couldn't resolve host name error whereas it works when trying to connect to

Any suggestions would be appreciated, thank you very much for the support!

1 Like

I am suspecting a DNS issue but I don’t really know. If I open qcg and qcdb without the proxy , the behaviour is different. qcg “spins” whereas qcdb fails immediately (“server not found”). Nevertheless as soon as I launch the proxy both work.

@grigoras @awegrzyn any idea ?

As the machine has a non-routable IP address:

$ host is an alias for has address

it will only be reachable from within CERN. So access via lxplus or a proxy with a public IP address is required for this address.



@grigoras The problem is that connecting via proxy does not work for some people. Their proxy work with qcg, not with qcdb.

It works for me, but as far as I remember this subnet will not accessible even from GPN at some point. I’d contact Uli for more details.

Dear all,

this issue we still have unresolved. Unfortunately, @awegrzyn I do not know, whom you mean with “Uli”, can someone contact him?

Thanks and cheers,

Barth will contact Uli.
Could you just confirm that curl from lxplus does not work for you?



Hm, but now I am wondering, this command actually does work, at least I think so. I get:




Still, I cannot access the QCDB in the browser, while the QCG is working fine.

Hi, yes that’s correct response.
This might mean SOCKS proxy or your browser misconfiguration, but can’t tell what, and indeed it’s weird that you can reach routable GPN addresses.

Just to be sure that we are on the same page, could you summarize which commands you execute where and which settings are set and where ?

I follow exactly the instructions provided on the shifter instruction page (as written above) in the part " Accessing from outside CERN", i.e.:

  • In a terminal, start a socks proxy with:
ssh -D 12345
  • The same I also tried using lxplus8 instead, with the same outcome.
  • Then I go in the firefox preferences → Network settings
  • There I change everything concerning the instructions (Manual proxy, localhost, correct port (12345, I also tried different ones, for sure as well for the connection in the first place), and socks_v5)
  • With this I am able to successfully run the command provided by Adam in the terminal, where I am connected to lxplus, and I am able to access the QCG in the firefox, but not the QCDB.

Hi @sheckel
I am just seeing this now. Since I do not see it in the shifter instructions for QC: Did you tick the box Proxy DNS when using SOCKS v5 in the manual proxy settings page of firefox? This box should be ticked. At least we needed it also for some pages for the PDP shifters. Could you try if that works for you?

1 Like

Hi @oschmidt

thanks a lot for this important piece of information. You got it, ticking this box I am now also able again to access the QCDB! I am very happy this finally could be solved! :smiley:
This info should be added in the shifter instructions!


Great !

I have added this point to the instructions.