O2 build fails on Python@v3.6.10


I am building O2+QC on Ubuntu 18.04. I do this very often and usually I have no issues but today I got an error when building Python@v3.6.10 and I am not sure how to solve it.

==> Building Python@v3.6.10
==> Python is being built (use --debug for full output): failed
ERROR: Error while executing /home/tomas/alice/sw/SPECS/ubuntu1804_x86-64/Python/v3.6.10-1/build.sh on `th-ubuntu'.
ERROR: Log can be found in /home/tomas/alice/sw/BUILD/Python-latest/log.
ERROR: Please upload it to CERNBox/Dropbox if you intend to request support.
ERROR: Build directory is /home/tomas/alice/sw/BUILD/Python-latest/Python.

Here is the log file: CERNBox

I would be glad for any pointers to the source of the problem. The only thing that comes to mind is trying to checkout and older version of O2+QC and try to build that.


I am by far an expert with Ubuntu and I don’t have a system to test. Things you could try:

  1. rm -rf sw → rebuild everything
  2. install python 3.6.10 with apt to avoid the compilation inside alibuild

Perhaps @hristov has an idea as well ?
I had a quick look at the logs but there are no errors there ?


Hi Barth,

Thanks for the help, but things did not go very well.

  1. I deleted the sw folder and tried again but I get the same error as before.
  2. I installed python 3.6.10 but after that aliDoctor complained that it is missing correct python version on the system and I could not even run aliBuild. I tried to downgrade back to the 3.6.9 (which was the system default version) but in the process the Ubuntu system was destroyed as it is sensitive to removing python packages.

In the end I had to reinstall my entire system. In the process I upgraded from Ubuntu 18.04 to Ubuntu 20.04. With the newer system the installation of Python@v3.6.10 worked fine.

TLDR: Solution is to upgrade Ubuntu from 18.04 to 20.04.


ok, sorry that it went that far. Happy that it worked in the end.