O2-sim fails on lxplus

Dear all,
I tried to run a simulation running o2-sim on lxplus and I am facing some problem.
I tried loading 3 different packages:
[1] /cvmfs/alice.cern.ch/bin/alienv enter [VO_ALICE@O2::v1.2.0-1]
[2] /cvmfs/alice.cern.ch/bin/alienv enter VO_ALICE@O2::nightly-20200422-1
[3] /cvmfs/alice.cern.ch/bin/alienv enter VO_ALICE@O2::nightly-20200409-1

Well, in all cases the simulation does not even start, and the system gives an error when loadin some shared libraries (libglfw.so.3 in the first and third cases, libVMC.so.6.20 in the second one).

Can someone, please, help me fixing this issue to properly run on lxplus?

Thanks a lot in advance for your help,

Looks like our CVMFS software stack is not build deep enough and incomplete. Thanks for pointing this out.

@eulisse : I guess the CVMFS stack should be built on machine with minimal system requirements. That should already improve the situation.

@swenzel It’s built on the same kind of container which we use for AliRoot / AliPhysics. I think the glfw issue comes from the fact we decided it was an optional requirement. Did you try with -b?
Regarding VMC, what was the error? Can you run with LD_DEBUG=files and provide the log?

These are all missing libraries shown by unresolved entries in ldd o2-sim. (Giving option -b will not help as the execution does not get that far.) In my understanding, the problem is that on the build server the executable was linked against libglfw which is then missing on the target machine.

I made a ticket on JIRA https://alice.its.cern.ch/jira/browse/O2-1390, to follow this up.