O2Physics build failed - 'source_location' file not found

I’m on a MacOS Ventura 13.6.1 and I’m not able to build O2Physics anymore. First I faced the problem mentioned in this topic: aliceO2 compilation failed, Python-modules-list

I updated aliBuild and the problem was solved but now I am facing other errors:

[226/5103] Building CXX object Utilities/DataSampling/CMakeFiles/O2lib-DataSampling.dir/src/DataSampling.cxx.o
FAILED: Utilities/DataSampling/CMakeFiles/O2lib-DataSampling.dir/src/DataSampling.cxx.o

In file included from /Users/clotteau/alice/sw/SOURCES/O2/daily-20240214-0100/daily-20240214-0100/Framework/Core/include/Framework/ServiceRegistryHelpers.h:15:
/Users/clotteau/alice/sw/SOURCES/O2/daily-20240214-0100/daily-20240214-0100/Framework/Foundation/include/Framework/TypeIdHelpers.h:18:10: fatal error: ‘source_location’ file not found
#include <source_location>

Finally, the last lines of the log file:
[233/5103] Building CXX object Utilities/rANS/CMakeFiles/O2test-rans-Serialize.dir/test/test_ransSerialize.cxx.o
ninja: build stopped: subcommand failed.

Hi @clotteau, this is an indication that your Xcode version is too old and does not support C++20 features. Could you update Xcode via the app store and the Command Line Tools via the “system update” menu in Preferences?

Thank you, I updated Xcode to version 15.2 and the command aliBuild build O2Physics worked