O2Physics build fails on macos Monterey 12.6

Hi, I am trying to build O2Physics and I ran into a problem with building O2Physics@master. The build crashes at the very beginning due to /Users/sarahaidlova/alisw/sw/SOURCES/O2Physics/master/0/PWGEM/Dilepton/Tasks/lmeeLFCocktail.cxx:32:10: fatal error: ‘nlohmann/json.hpp’ file not found
#include <nlohmann/json.hpp>.
I know this nlohmann package is installed by brew, it is installed and up to date, to be sure I included it in the path, however it did not resolve anything.
Link to full log file including this error is in: CERNBox
Thank you very much for your help,

Hi Sara,

I am facing the same issue fatal error: ‘nlohmann/json.hpp’ file not found
#include <nlohmann/json.hpp>. while building O2Physics@master in Mac OS Ventura 13.1.

Did you manage to solve the issue?

Thanks for the help.

Hi Swapnesh,
I did manage to solve the issue, but the solution is quite tiresome. I manually added full path to the packages, unfortunately I couldn’t find a better solution, but the build worked afterwards. Please let me know if you find something more efficient!