O2Physics build fails on Ubuntu 23.10

Dear all,

I have been facing a problem while installing O2Physics on my Ubuntu 23.10 system. I have been following the instructions given at

The initial steps seem to be working fine, but after the

aliBuild build O2Physics

command, the installation fails, displaying the following lines on terminal :

ApMon-CPP is being built (use --debug for full output): failed
ERROR: Error while executing /home/jessica/alice/sw/SPECS/ubuntu2310_x86-64/ApMon-CPP/v2.2.8-alice5-local1/build.sh on `jessica-HP-Laptop-15s-fr1xxx'.
ERROR: Log can be found in /home/jessica/alice/sw/BUILD/ApMon-CPP-latest/log
ERROR: Please upload it to CERNBox/Dropbox if you intend to request support.
ERROR: Build directory is /home/jessica/alice/sw/BUILD/ApMon-CPP-latest/ApMon-CPP.

The link to the Log file is here :


Please suggest me the necessary steps to be taken to resolve this problem. Thanks in advance !

Hi Jessica,

at the moment I would recommend you to use Ubuntu 22.04 and not the newer 23.10. I have tried 23.10 myself in a VM and while the ApMon-CPP issue was easy to fix (Add missing cstdint include by martenole · Pull Request #8 · alisw/apmon-cpp · GitHub) there are then other packages which also don’t compile out of the box like GEANT and pythia.

It might work if you installed an older compiler version and used that instead of gcc 13.2, but this I haven’t tried yet. So I would really just go to ubuntu 22.04 which many people are using and where the installation works very easily.


1 Like