Problem building O2 Python-Modules Ububtu 19.10

Dear experts:

I am trying to build O2 on Ubuntu 19.01 I follow the steps to install using docker and alidock environment.

The error message is:

DEBUG:O2:Python-modules:0: Complete output from command python egg_info:
DEBUG:O2:Python-modules:0: Traceback (most recent call last):
DEBUG:O2:Python-modules:0: File “”, line 1, in
DEBUG:O2:Python-modules:0: ModuleNotFoundError: No module named ‘setuptools’
DEBUG:O2:Python-modules:0: ----------------------------------------
DEBUG:O2:Python-modules:0: Command “python egg_info” failed with error code 1 in /tmp/pip-install-0v7akt0t/PyYAML/
DEBUG:O2:Python-modules:0: You are using pip version 18.1, however version 20.2b1 is available.
DEBUG:O2:Python-modules:0: You should consider upgrading via the ‘pip install --upgrade pip’ command.
ERROR:O2:Python-modules:0: Error while executing /home/alidock/.sw/SPECS/slc7_x86-64/Python-modules/1.0-1/ on `alidock-1000’.
ERROR:O2:Python-modules:0: Log can be found in /home/alidock/.sw/BUILD/Python-modules-latest/log.
ERROR:O2:Python-modules:0: Please upload it to CERNBox/Dropbox if you intend to request support.
ERROR:O2:Python-modules:0: Build directory is /home/alidock/.sw/BUILD/Python-modules-latest/Python-modules.

I tried:

aliBuild clean --aggressive

and nothing, still the same error. Also tried:


also update update alidist and O2 but still nothing.

If someone can help me I really appreciate that.

Have a nice day.

It’s a known issue. This will be fixed tomorrow via

1 Like

Thank you very much .

I just finished the installation. Some warning about not fetched … but I hope no mayor issues.

Regards! Have a nice day! :grinning: