Problem compiling O2 on CC7

Hi,

today I have issues compiling O2 on CC7. After removing alice/alidist alice/O2 and alice/sw and reinstalling from scratch I have the following message:
aliBuild build O2 --defaults o2

/home/cortese/.local/lib/python2.7/site-packages/requests/init.py:91: RequestsDependencyWarning: urllib3 (1.25.10) or chardet (2.2.1) doesn’t match a supported version!
RequestsDependencyWarning)
ERROR: The following development packages have wrong spelling: CMake, generators.
ERROR: Please check your local checkout and adapt to the correct one indicated.

Do you have any suggestion?
Thanks,
Pietro

Can get rid of the part of the error message concerning python by uninstalling the package requests and urllib3 that were installed by pip and installing the ones provided by yum.
Perhaps someone should add the two packages python-urllib3 python-requests to the prerequisites for installation.

The last two errors are still present.

After cleaning some files left in the directory ~/alice the compilation is starting