Problem with ReadoutCard@v0.15.0 for QC

Dear all,

I am encountering a problem while building QualityControl following the instructions on Github.

The logs can be found here: https://cernbox.cern.ch/index.php/s/dZr4erdPU5QF36U and https://cernbox.cern.ch/index.php/s/IBvAstL0PsBbOUK
I am working on Ubuntu 16.04. I installed O2 from scratch yesterday and alidist is up-to-date.

Thank you for your help,
Best,
Cindy

Hello,

Thank you for your report. I am not familiar with Ubuntu but I would suspect that it is related to the use of 16.04.
I’ll try to install Ubuntu 16.04 but it will take a bit of time.

If you wish you could also install CC7 in a VM.
Cheers,
Barth

Hi,
I am not able to set up a machine under Ubuntu 16 with the requirements specified here : https://alice-doc.github.io/alice-analysis-tutorial/building/prereq-ubuntu.html

I get :

bvonhall@ubuntu:~$ sudo pip install matplotlib numpy certifi ipython==5.1.0 ipywidgets ipykernel notebook metakernel pyyaml
The directory '/home/bvonhall/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/bvonhall/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting matplotlib
  Downloading https://files.pythonhosted.org/packages/75/81/53ccadcb8cad0a9837f1487b57f2b46b21caa2b3f35f72bc1acb06b5825c/matplotlib-3.1.2.tar.gz (40.9MB)
    100% |████████████████████████████████| 40.9MB 47kB/s 
    Complete output from command python setup.py egg_info:
    
    Beginning with Matplotlib 3.1, Python 3.6 or above is required.
    
    This may be due to an out of date pip.
    
    Make sure you have pip >= 9.0.1.

@eulisse do you know if ubuntu 16 is still supported for O2 ?

In principle it’s not supported. Can’t you update to a later version?

I let Cindy reply concerning updating.

@eulisse I have just checked and the pages describing the installation of O2 are happily advertising support for Ubuntu 16.04 : https://alice-doc.github.io/alice-analysis-tutorial/building/prereq-ubuntu.html
Is it because of AliRoot ? Can we remove the references to this version ?

@ihrivnac You might be interested as well in this discussion.

Yes, I think this was meant to be for AliRoot. IIRC we always said that for O2 only slc7 was officially supported.

Hello,

Thanks a lot for your answers and great help.

Using a VM seems pretty compromised with my current installation. However, updating to Ubuntu 18.04 should be feasible in a close future, yes. I will try and see if then I can install properly O2 and QC.

Cheers,
Cindy