I am trying to update to the new firmware version v2.6.0 with the associated cru-sw. When trying to execute the script from the COMMON folder, I get the following error message:

[root@gemini COMMON]# python -i 3b:0.0 -c local

Firmware short hash=0x9bf047b2
Firmware build date and time=20181109 163741
Altera chip ID=0x00540188-0x10d2ff03
Starting TTC PON calibration
Traceback (most recent call last):
File “”, line 35, in
cru.ttc.selectGlobal240(args.clock, args.devkit)
TypeError: selectGlobal240() takes exactly 2 arguments (3 given)

OK, I think I solved this by myself:

It looks like I had a bunch of .pyc files in the directory from which I executed the script, which must not have been updated. After deleting all .pyc files, the script finally executed without further error messages.


Thanks for posting the solution. I actually had the same problem two days ago, I did a fresh clone to solve it. I guess the following would have yield the same result:

git clean -d -x -f



yes, this is a known “feature” of python and can create quite some mess since .pyc are not necessarily updated. There are two solutions here:

  1. Delete all the .pyc files :
find . -name '*.pyc' -delete
  1. run python with the “-B” option. It won’t compile the python code into bytecode and store it into a .pyc file.