TPC-ITS matching workflow not working

Hello @shahoian ,

when trying to run o2-tpcits-match-workflow I get an error from the tpc-track-reader (“Error opening tree”). I tried changing the TrackReader::mTrackTreeName from “tpcrec” to “events”, as this is the name for the tree stored in the tpctracks.root file but then I get a segfault from the accumulate method in the same device.

To be more precise I tried all steps described in the readme of the GlobalTrackingWorkflow and this then fails than at the TPC-ITS matching stage.


Hi @oschmidt

there should be no events tree in the tpctracks.root. I’ve just tried:

o2-sim -n10 -m PIPE ITS TPC TOF 
o2-tpc-reco-workflow  --input-type digits --output-type clusters,tracks --configKeyValues "GPU_proc.ompThreads=4;" --shm-segment-size 10000000000  --run | tee recTPC.log
o2-its-reco-workflow --trackerCA --tracking-mode async --shm-segment-size 10000000000  --run | tee recITS.log
o2-tpcits-match-workflow  --tpc-track-reader tpctracks.root --tpc-native-cluster-reader "--infile tpc-native-clusters.root"  --shm-segment-size 10000000000  --run | tee recTPCITS.log

and it works w/o problems. The AliceO2/Detectors/GlobalTrackingWorkflow at dev · AliceO2Group/AliceO2 · GitHub mentions --tpc-digit-reader '--infile tpcdigits.root' in the o2-tpc-reco-workflow, but this is anyway default.

Indeed, yes, now it works for me too. When I switched to the cosmics example workflows I forgot that I did not recompile O2 after setting TrackReader::mTrackTreeName back to the default.
When I tried it at first I still had an old list of commands taken from my notes specifying --tpc-track-writer "--treename events". That was my problem.
Sorry for that and thanks a lot for checking!