XRootD@v4.11.1 Problem while building O2 in Fedora-28

Hi Experts,

I am facing some issues in XRootD@v4.11.1 during building O2 in Fedora-28 with the command:
AliBuild build O2 --defaults o2 and give the errors:
Using cached build for arrow

==> Building XRootD@v4.11.1
==> XRootD is being built (use --debug for full output): failed
ERROR: Error while executing /home/user/alice/sw/SPECS/fedora28_x86-64/XRootD/v4.11.1-local1/build.sh on `localhost.localdomain’.
ERROR: Log can be found in /home/user/alice/sw/BUILD/XRootD-latest/log
ERROR: Please upload it to CERNBox/Dropbox if you intend to request support.
ERROR: Build directory is /home/user/alice/sw/BUILD/XRootD-latest/XRootD.

The complete error log is also uploaded on the CERN-BOX as in the given link:

But, O2 seems to be built successfully after disabling XRootD with the following command:
aliBuild build O2 --defaults o2 --disable XRootD.

Here I seek some help to get rid of the compiling issue with XRootD so that I can use O2 with full dependencies.


the actual error from the log is:

cc1plus: fatal error: inaccessible plugin file /home/user/alice/sw/fedora28_x86-64/GCC-Toolchain/v10.2.0-alice2-local1/bin/../lib/gcc/x86_64-unknown-linux-gnu/10.2.0/plugin/annobin.so expanded from short plugin name annobin: No such file or directory
compilation terminated.

that point to the lack of annobin plugin which is strange that is not present
anyway, try to upgrade the alidist as o2 defaults were updated to use the latest xrootd 4.x version
moreover try to move to latest fedora (34) as to make use of already available toolchain

Dear Adrian,

Thank you for your very prompt response to my problem. Yes, you are correct, I was trying to find the plugin annobin.so. But hard luck not getting it anywhere. I tried updating alidist by typing git pull --rebase, but no help by doing so. Or else if I may get this binary annobin.so for gcc toolchain 10.2.0.

Thanks again?

The annobin plugin si part of gcc toolchain, which in your case is built by alibuild, hence the suggestion to move to the latest fedora, where the system toolchain is used.
Moreover the suggestion to move to latest alidist comes from the fact that the latest master defaults-o2 use xrotod 4.12.8

Dear Adrian,

Thanks Again, I tried to update alidist and this time --defaults o2 uses XRootD@v4.12.8, but after this also the problem is same, which shows annobin.so is inaccessible.

Anuj Chandra