Building O2 fails at lhapdf@v6.1.6

Dear experts,
I am trying to build O2(nightly-20191001) but aliBuild fails on lhapdf@v6.1.6_02
I have the same error as in Building lhapdf@v6.1.6 fails
But I have the latest version of alidist in the folder where I am building O2.

Errors found in terminal:
ERROR:O2:lhapdf:0: Error while executing /home/tomas/cernbox/alice/sw/SPECS/ubuntu1604_x86-64/lhapdf/v6.1.6_O2-1/ on `Tomas’.

Error found in log file:
ERROR: Unable to download /cvmfs/
ERROR: Unable to download /afs/
Traceback (most recent call last):
File “/home/tomas/cernbox/alice/sw/INSTALLROOT/493db33dce41fcc242f36e360c89c4a22bdefc46/ubuntu1604_x86-64/lhapdf/v6.1.6_O2-1/bin/lhapdf”, line 527, in
if download_file(tar_filename, options.PDFDIR, dryrun=suboptions.DRYRUN):
File “/home/tomas/cernbox/alice/sw/INSTALLROOT/493db33dce41fcc242f36e360c89c4a22bdefc46/ubuntu1604_x86-64/lhapdf/v6.1.6_O2-1/bin/lhapdf”, line 450, in download_file
if download_url(source + filename, dest_dir, dryrun):
File “/home/tomas/cernbox/alice/sw/INSTALLROOT/493db33dce41fcc242f36e360c89c4a22bdefc46/ubuntu1604_x86-64/lhapdf/v6.1.6_O2-1/bin/lhapdf”, line 303, in download_url
file_size = int(‘Content-Length’)[0])
IndexError: list index out of range

I would be glad for any help.


Hello, I have quite the same issue. From a fresh Ubuntu 18.04, the o2 compilation fails on this lhapdf issue. Did you solved this?
Best regards, FM

for me the error was a rather stupid mistake on my side. I did not understand correctly the guide in

The point is that when I was doing

git checkout master  # use dev instead of master for O2
git pull --rebase

I did these commands in the alidist folder with the dev option, however one needs to do the command with the master option in all directories (alidist, aliphysics…) and only in the O2 directory one has to go with the dev option. Then it compiled.

Best regards,

Dear Tomas, dear all,

to clarify maybe a bit further, what you call an option in fact is the name of the corresponding git branch. Usually, the standard branch is called master in most git repositories, but in case of O2 it has been named dev.

If, in a given repository, you would like to find out, which branches exist in your local checkout, you can e.g. use:
git branch -vv
It will show you all the local branches together with some additional info, like the corresponding remote branch.

Hope, it helps!