O2 Simmulations fails due to internal-dpl-ccdb-backend


I am using O2 simulations tool. The simulation run for o2-sim -m TPC [ITS PIPE] -n 100 and sequentially digitization using o2-sim-digitizer-workflow -b but throws errors in o2-tpc-reco-workflow --infile tpcdigits.root which are associated with 396457:internal-dpl-ccdb-backend with message [396457:internal-dpl-ccdb-backend]: [17:26:40][FATAL] Unable to find object CTP/Calib/OrbitReset/1651505164569

I am using O2 version from 2022-04-27 and QC version is 2022-04-27 on Ubuntu 20.

Anyone has an idea of what could be possible reason behind this error?

Best wishes,

This is a problem with using a timestamp for which no condition object exists on CCDB. A fix is in preparation. Should be available in the coming days.

Meanwhile you can put timestamps which fall in valid “run ranges”. It can be done in the following way:

o2-sim --timestamp 1635659148972 ...

Thanks for looking into it, However 2-sim -m TPC [ITS PIPE] -n 100 works but the reconstruction work flow o2-tpc-reco-workflow --infile tpcdigits.root crashes due to internal-dpl-ccdb-backend

As per your suggestion I tried o2-tpc-reco-workflow --infile tpcdigits.root --timestamp 1635659148972 however it still searches for the most recent object which leads to a crash. I am wondering if the
command I used is correct ?


What is an exact message from the ccdb-backend now?
In your working directory there should be a file o2simdigitizerworkflow_configuration.ini, can you do

grep -A10 HBFU o2simdigitizerworkflow_configuration.ini

and post here what it shows?

You need to apply the timestamp during o2-sim not reconstruction. Then all the remaining steps such as digitization and reco should also use this timestamp.

After simulation with o2-sim -m TPC [ITS PIPE] -n 100 --timestamp 1635659148972 the reconstruction fails when I perform o2-tpc-reco-workflow --infile tpcdigits.root with error

  • [464145:tpc-zsEncoder]: [17:21:04][INFO] Sending end-of-stream message to channel from_tpc-zsEncoder_to_tpc-tracker
  • [464144:internal-dpl-ccdb-backend]: [17:21:04][WARN] CCDB: Did not find an alien token; Cannot serve objects located on alien://
    * [464144:internal-dpl-ccdb-backend]: [17:21:04][FATAL] Unable to find object CTP/Calib/OrbitReset/1635659148972
  • [464144:internal-dpl-ccdb-backend]: For later analysis we write a core dump to core_dump_464144
  • [464144:internal-dpl-ccdb-backend]: [17:21:20][STATE] Exiting FairMQ state machine
  • [464144:internal-dpl-ccdb-backend]: [17:21:20][FATAL] unknown error while setting up workflow in o2-tpc-reco-workflow.
  • [ERROR] pid 464144 crashed with 1

I have also tried passing the timestamp to subsequent steps after o2 -sim..

You need to have valid alien token to access the ccdb.

The object CTP/Calib/OrbitReset should exist for the mentioned timestamp:

o2-ccdb-downloadccdbfile --host http://alice-ccdb.cern.ch -p CTP/Calib/OrbitReset -t 1635659148972
[INFO] Is alien token present?: 1
Querying host http://alice-ccdb.cern.ch for path(s) CTP/Calib/OrbitReset ... and timestamp 1635659148972
Info in <TJAlienConnectionManager>: Opening connection to JCentral. Please wait
Info in <TJAlienConnectionManager>: Opening connection to
Info in <TJAlienConnectionManager>: Successfully connected to
Info in <TJAlienFile::Open>: Accessing file /alice/data/CCDB/CTP/Calib/OrbitReset/02/31550/cad957b0-3a0d-11ec-8119-0aa14064250c in SE <ALICE::CERN::EOS>
[TFile::Cp] Total 0.00 MB       |====================| 100.00 % [0.0 MB/s]

As Ruben said, you need a valid ALIEN token/certificate. Check output of alien-token-info.